Twitter API v1 Retirement is Complete

Несмотря на годовую подготовку к прекращению работы старого API v1.0, для большинства разработчиков переход на новую версию 1.1 создал некоторые трудности.
Во-первых, это обусловлено тем, что создатель библиотеки Twitterizer перестал ее поддерживать еще полгода назад, а внести нужные изменения в открытый код из 10 тыс. разработчиков за полгода никто так и не решился. Разве что один японец вызвался добровольцем. По факту, соответствующие изменения я тоже внес в BlogsAPI.
Проблемы с переходом на новую версию следующие:

1) Изменения в функции поиска (Search), она сейчас у всех барахлит. К слову, через месяц фейсбук тоже уменьшит функциональные возможности у поискового сервиса.
2) Запрет на получение related_tweets - что делает сложным определять дискуссии. Видимо это сделано специально, одновременно с открытием платформы TwitterAnalitycs, теперь все другие аналитические платформы будут гарантированно иметь худщий функционал.
3) Запрет на создание динамических виджетов с результатами поиска. Опять же позволит твиттеру сильно уменьшить нагрузку на свои сервисы.

И ко всему прочему у многих разработчиков рандомно вываливаются ошибки вида Error 401: Unauthorized {"message": "Could not authenticate you","code":32} . При этом запрос правильно составлен и подписан.

Метки: , , , ,   


Кто я?

Программист. Я слежу за блогосферой и знаю, как будет развиваться интернет. Когда у меня есть время я даже прилагаю для этого усилия. Подробнее

Последние комментарии

Не отображать

Topbot at FeedsBurner
 

копирайт

Все мысли, высказанные в блоге, являются моим мнением и за это мнение меня никто не забанит! Кроме того, никто не имеет право копировать материалы блога без использования ctrl+C/V!

© Copyright 2008